Syphon Recorder Error on 10.11 El Capitan

Home Forums Syphon Syphon Development – Developer Syphon Recorder Error on 10.11 El Capitan

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #59120
    jgrl
    Participant

    Hey there! Firstly, I love Syphon, and what you’ve done is completely amazing.

    I just wanted to let you know that I’ve run across what seems to be a bug in Syphon Recorder that’s only been happening since I upgraded my system to 10.11/El Capitan yesterday. To repro:

    1. Launch Simple Server (or any other Syphon Source) first.
    2. Launch Syphon Recorder next, and start recording Simple Server’s output.
    3. Notice that the screen doesn’t contract vertically like it used to (seems to fail to do this 70% of the time), so the Syphon stream is still shown in the window while capturing.
    4. Clicking the stop recording button will cause a quite noticeable delay. Sometimes this results in the video showing up in Quicktime Player and sometime it results in OSStatus error -2020 with no movie saved.

    Screenshot of Error

    I’d love to help out however I can. I’m a developer, so I was looking for the source of the Recorder to see what might be the problem, but I’m not sure it’s open-source. Has anyone else encountered this, or knows anything I can do to work around it? Thanks!

    • This topic was modified 4 years, 9 months ago by jgrl. Reason: Image embedding didn't seem to work!
    #59122
    bangnoise
    Keymaster

    Thanks for the report – something does seem to be awry on 10.11. I’ll take a look at it. Recorder is closed source – for better or worse 😉

    #59124
    jgrl
    Participant

    Wonderful, that’s great to hear – thank you for looking into it! 😀

    #59144
    jonra
    Participant

    Yes, I too love Syphon Recorder and have inherited the El Capitan 10.11 Record issue, any solutions ?

    #59169
    drostev
    Participant

    Any word on whether this bug is still a problem? It is currently one of the few concerns blocking my upgrade path.

    #59181
    bangnoise
    Keymaster

    There’s a new version fixing 10.11 issues at http://syphon.v002.info/recorder/

    It would be good to hear if it solves yr problems.

    • This reply was modified 4 years, 5 months ago by bangnoise. Reason: link to release
    #59182
    jgrl
    Participant

    Fantastic work – I’ve been using it this morning and haven’t had any more issues with it on 10.11! Of course I’ll post here if I do experience anything, but it is already way more stable than it was in version 13.

    #59184
    bangnoise
    Keymaster

    That release (14) introduced a new issue which could cause the check for new versions to fail – if you’ve downloaded 14, grab the update from http://syphon.v002.info/recorder/

    Sorry about that.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.