Syphon, QC & Xcode

Home Forums Syphon Syphon Implementations – User Syphon, QC & Xcode

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #17147

    Hi everybody,

    I’m trying to make a standalone application of a qtz file that inclues a syphon patch.

    Because i’m not a developper, i do this in the following way :

    – I choose cocoa application on Xcode

    – I add Quartzcomposer.frameworks

    – I add a quartz composer view and load my qtz file

    – I also add a quartz composer patch controller because i would like to control some inputs with sliders and text field.

    To make the bindings, I have to load the qtz file into the quartz composer patch.

    When I do this, Xcode says

    “The Composition loaded, but there were issues. Check Console for details.”

    I think this is a problem from the Syphon patch, because when I delete it in my qtz file, there is no issue on Xcode.

    Is someone have an idea ?

    I’m using Xcode 4.2 on a 10.6.8 iMac.

    sorry for my english 🙂




    Console message :

    2013-01-17 22:27:35.083 ff[84480:903] *** <QCNodeManager | namespace = “” | 349 nodes>: Bundle at path “/Users/dam/Library/Graphics/Quartz Composer Patches/Syphon.plugin” is not a valid Graph Foundation plug-in

    2013-01-17 22:27:35.118 ff[84480:903] *** QCPlugIn: There is already a QCPlugIn registered for class “SyphonServerQCPlugIn”

    2013-01-17 22:27:35.121 ff[84480:903] *** QCPlugIn: There is already a QCPlugIn registered for class “SyphonClientQCPlugIn”

    2013-01-17 22:27:35.121 ff[84480:903] *** QCPlugIn: There is already a QCPlugIn registered for class “SyphonServerListQCPlugIn”


    This looks like a problem with our support for garbage collection in the framework.

    If you can hook things up in Xcode with the Syphon patch removed from your QC composition, then switch it in when you run your app, it should work. If that’s a pain then we can look at providing you with a fixed framework version. Sorry ’bout that…


    Hello bangnoise,

    As you said, I just tried to make all bindings without Syphon Patch in my QC Composition.

    After that, I put the Syphon in my QC composition and reloaded the qtz in the QCView & QC Patch Controller.

    Then, I run my app. The binding works but I can’t see it in Madmapper :/


    For now, here’s a version of the plugin with a fix for the problem. We’ll try to get a new release out soon.

    Are you planning to distribute the finished app? If so, you’ll have to include and load a version of the plugin and be able to handle conflicts with any installed version users may already have – which is a whole other kettle of fish…



    I removed the old syphon plugin by yours, However when I open Quartz Composer I have this message, and now I can’t make a project :/


    Ummmmm… weird. Can you restart your machine and remove all the third-party plugins you have installed, then add them back one by one, starting QC each time to see if you still have the issue – just to be sure it is the fault of Syphon.


    I restarted my computer and deleted all plugins. When I put the syphon.plugin in Macintosh > Library > Graphics… => Same Bug

    In User > Library > Graphics > Qc Plugin => Same Bug.



    Sorry ’bout that – I’ve put up a new version – this one really should work

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.