Resize Image on Server causes client fail using QC comps.

Home Forums Syphon Syphon Implementations – User Resize Image on Server causes client fail using QC comps.

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #6239
    usefuldesign.au
    Participant

    I have a QC comp sending a 4:3 image with Syphon Server patch and another comp using Client to receive it. Based on sample comps. When I resize the Server image (either by resizing the Viewer window using OpenGL mode or increasing the Pixel Dimensions of Render in Image patch using image input) I find the receiver comp falls over. It drops the image outputting blank and when I restart the comp I get that double–the size-it-should-be-bug on the billboard people might be familiar with.

    I can post comps if that helps but there’s very little going on. I haven’t been on these forums for a few months and missed the initial Syphon gold-rush so not sure if this is a known issue or not.

    EDIT:
    Also noticed that when Syphon is serving an image from a QC Comp using a feed from an Render in Image patch to it’s image input and the view is resized (smaller or larger) it will knock over the comp receiving the image. This is a big problem for me as I need to able to adjust my composition viewing window. I tried disabling a billboard that displayed the Render in Image Output that is sent to the Syphon Server patch but it didn’t help.

    • This topic was modified 8 years, 4 months ago by usefuldesign.au. Reason: Another observation ยป
    #6241
    usefuldesign.au
    Participant

    I’m on 10.7.4 Kineme Plugins only installed.

    #6243
    vade
    Keymaster

    Post comps please, and what to do to trigger the issue.

    #6245
    usefuldesign.au
    Participant

    Okay will reduce Server comp as much as I can first.

    #6247
    bangnoise
    Keymaster

    I can reproduce most of this, we’re investigating. In the meantime, if you’re able to fix the pixel dimensions of your RII patch, that should at least avoid the problem.

    #6248
    usefuldesign.au
    Participant

    Oh thanks wont reduce comp then. Yes I’ve found with locked off dimension and using image input I’m sweet. I just took it up to 1280×960 and shrinking the Viewer window to small sizes like 360px is not breaking Client comp viewer window now. ๐Ÿ™‚

    That double-the-size-it-should-be bug always scares me though in other plugins and if it wasn’t you two dev’s I’d be banishing the plugin for a while ๐Ÿ˜‰

    • This reply was modified 8 years, 4 months ago by usefuldesign.au. Reason: extra comment
    #6250
    bangnoise
    Keymaster

    tracked as issue 20.

    #6251
    vade
    Keymaster

    Hrm – I can’t re-create this here.

    https://dl.dropbox.com/u/42612525/Syphon%20QC%20Issue%2020.zip

    Resizing the Servers viewer seems ok with both GL and Image input, client always outputs an image – but I do get some occasional visual garbage if using OpenGL mode and resizing quickly.

    #6254
    usefuldesign.au
    Participant

    https://dl.dropbox.com/u/42612525/Syphon%20QC%20Issue%2020.zip

    That demo falls over here when I resize the Server Comp view window. Client just shows a blank.

    #6255
    vade
    Keymaster

    I still cannot reproduce here, but @bangnoise can. What computer, OS, and GPU do you have?

    #6256
    usefuldesign.au
    Participant

    10.7.4
    MBP 8,3 17″ 2.2 Ghz i7
    AMD Radeon HD 6750M 1GB

    sent you a system report via email

    #6260
    vade
    Keymaster

    Thanks. Bangnoise and I took a look at this, and think we nixed the issue. Any chance you can try out this build and report back?

    I realized I was testing a version with some changes, not the release (apologies for that) – and was able to re-create.

    This linked build should have the fixes for your bug – as well as a fix so that when a Syphon Server is publishing an image that is disconnected, or is sent a “nil” image, it continues to send the last frame, and doesn’t “vanish” (a request from other users).

    Please let us know how this works for you, and thanks for finding and reporting the bug.

    http://syphon.v002.info/downloads/SyphonQCBeta2R2.plugin.zip

    #6261
    vade
    Keymaster

    Just as a note, this is marked as Beta 2 Release 2 (in get info), so you know what the versions are. Thanks.

    #6264
    usefuldesign.au
    Participant

    I tried your demo comps using Syphon public beta r2 and it still falls over in Client window when I re-size Server Viewer window. After that restarting the Viewer gives a double plus a Y-axis stretch in the Viewer. Not ever single time you resize Server but at certain unknown trigger points.

    #6266
    bangnoise
    Keymaster

    Can you check you don’t have two versions of the plugin installed and did install the version vade linked above? Check in /Library/Graphics/Quartz Composer Plug-Ins and in your Home Folder/Library/Graphics/Quartz Composer Plug-Ins.

    I could reproduce the issue before and can’t with the version linked above.

    #6267
    usefuldesign.au
    Participant

    Ooops I did update to r2 but must have forgotten to restart QC. This is rock&roll now (cool nice fix).

    #6268
    bangnoise
    Keymaster

    Cool, thanks for verifying. We’ll get a new download up soon.

Viewing 17 posts - 1 through 17 (of 17 total)
  • You must be logged in to reply to this topic.