Syphon Virtual Screen (again!)

Home Forums Syphon Syphon Implementations – User Syphon Virtual Screen (again!)

  • This topic has 51 replies, 14 voices, and was last updated 3 months ago by Andrea Cremaschi.
Viewing 12 posts - 41 through 52 (of 52 total)
  • Author
  • #35427

    Hello and congratulations for this software.
    Is there a version that allows to have a custom output resolution ?
    I want to use with Isadora for a virtual output consists of a TripleHead2Go + another screen.
    4 X 800 X 600 = 3200 X 600
    In advance thank you!


    Can’t you just use a Syphon Server in Isadora and set its resolution? Isadora can host Quartz Composer patches, and people have shared Syphon patches on the Isadora forums. I’d look into that approach rather than this.

    Andrea Cremaschi

    Me too..
    If you can’t do without SVS check the instructions on how to use custom resolutions on the project homepage:


    Thanks Vade and Andrea (I’ll try to customize the resolution)
    Here is the question I ask about Isadora forums:
    My configuration: 1 output> TripleHead> 3 videoprojector, 1 output> 1 videoprojector.
    I want to receive MadMapper in a single image of the 4 screens.
    If I use the actor “Syphon Stage Output” I need two stages. (TripleHead + 1 Screen).
    MadMapper but can only receive one Syphon Server!
    I want to project a TripleHead + screen side by side picture.


    Hi Andrea.

    Trying to get SvS working with Final Cut pro X, but fcp will not recognize the virtual display.

    I´m on Mavericks, and had an issue installing from binary:
    After installing package, there was no program in the program folder to replace.

    Nonetheless, it is working fine with Q-lab.

    Any thoughts?

    Andrea Cremaschi

    Hi boya,
    sorry, no clues, I have never tried to make it work with FCPX. As it is working with qlab it should be correctly registered as a monitor, maybe it is not enough for fcpx to use it as a preview screen, some other requirement could be needed. “no problem in problem folder” is weird too, could you file an issue on github to keep track of it?
    Just for curiosity, what are you trying to accomplish?


    Sorry to say, I´ve fooled myself as a late switcher from fcp7 to fcpx.
    But happy to say it seems to be working with fcpx! – but not fcp7.

    Great, because I was using the FCP syphon server mock-up from Vade, for edition live from final cut via quartz composer to four or six projection screens. It works, somehow, with fcp7 but not fcpx.

    I was thinking loads more people would be doing this by now:
    Working right from an editor onto a custom stage environment, you´d need expensive stuff like Dataton, which gives you a fraction of the possibilities.

    So, off to do the custom console stuff to get the preferred resolution, which in my case would be 2048 x 2304

    Thanks for your work, I´ll try to post the “no problem in problem folder”
    -sound great, that!



    I’m having trouble installing SVS on a MBP running 10.8.5

    I installed SVS on a machine running 10.9.1 with no problem, but on the 10.8 machine the SVS icon is RED in the tool bar and the drop down menu says “Driver Not Loaded” and “Enable Syphon server” is greyed out.

    The application is located in the appropriate folder, and the driver EXProxyFramebuffer.kext is located in the /System/Library/Extensions directory.

    I tried manually loading the driver through Terminal with

    sudo kextload /System/Library/EWProxyFramebuffer.kext

    and Terminal responded with

    /System/Library/EWProxyFramebuffer.kext failed to load – (libkern/kext) not found; check the system/kernel logs for errors or try kextutil(8)

    I checked Console and found this

    1/8/14 9:10:50.710 AM[12]: Can’t open CFBundle for /System/Library/EWProxyFramebuffer.kext.
    1/8/14 9:10:50.711 AM[12]: Can’t open CFBundle for /System/Library/EWProxyFramebuffer.kext.
    1/8/14 9:10:50.711 AM[12]: Error: Kext /System/Library/EWProxyFramebuffer.kext – not found/unable to create.

    I apologize that I’m fairly new to using terminal so I’m not entirely sure how to proceed

    Any guidance would be greatly appreciated


    So this is all very exciting but I seem to have come to the party late….

    I downloaded the installer from: and then went ahead and ran it on 10.8.5
    It took a long while to get through the last bit of the installation process…But all seemed fine.
    Sadly though I couldn’t get it to work.
    AND then I am faced with not being able to put my computer to sleep anymore!
    This seems to be the best source of info and I cannot fathom what I should have to do in order to get it working or to de-install it so at least my machine is not hosed.
    Help please.


    See the webpage you link for support info.

    At a guess, you need to remove EWProxyFramebuffer.kext from /System/Library/Extensions/ and reboot to uninstall it.


    Thanks Tom, glad to have sleep function back again 🙂


    Hello this may be newbie question but is there any way to make the mouse visible within the virtual screen? I find myself fishing for windows when I can’t see my cursor’s position.

    Also thank you for everyones’ contributions here, this community’s content has really been a big help for someone without a programming background.

    -Dan O.

Viewing 12 posts - 41 through 52 (of 52 total)
  • You must be logged in to reply to this topic.