Mipmaps for Unity Syphon Client Texture Projector

Home Forums v002 v002 QC Plugins Support Mipmaps for Unity Syphon Client Texture Projector

Tagged: , ,

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #58611


    I’m using the Unity Syphon plugin and specifically the Syphon Client Texture Projector script. I’m projecting across the whole scene to achieve a kind of anamorphic illusion where the camera starts at the same position as the projector so the image looks 2D, but then reveals the 3D geometry when the camera moves away from the projector.

    Here’s the effect in action with a static image on a conventional Unity Texture: https://vimeo.com/87241677

    I’m now trying to convert that effect to use the Syphon Texture Projector script to swap that static image out with live video from a Syphon source.

    I got the Syphon Client Texture Projector hooked up and achieving basically the same effect. However, there seems to be a problem with the mipmapping on the Syphon Client Texture Projector:

    Syphon Client Texture Projector

    I had a similar glitch when I first started designing this effect with the traditional Unity Texture that I fixed through some black magic combination of turning on and off mipmapping-related options in the Advanced Texture Import menu (I think Unity caches the mipmaps even after you hit apply so it’s hard to tell which set of options it’s actually applying). Maybe one of the options having to do with mipmapping for the borders of the texture?

    Is it possible to turn on mipmapping for the Syphon Client Texture Projector in code within the script? (I couldn’t find any appropriate method in the docs.) Or is there some other solution to this? Maybe in the shader?



    Is it possible that the syphon texture is not outputting at a 2^x based pixel count? ie 2×2, 8×8, 64×64, 1024×1024 etc…. Fire up Quartz and verify your Syphon output with the same texture rez and verify with a Rendering Destination Dimensions patch.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.