Headless Syphon Problem?

Home Forums Syphon Syphon Implementations – User Headless Syphon Problem?

Tagged: ,

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #58868

    Hi. I have an app that requires using Syphon to pass a stream from Max to Processing, and that is in turn sent out over USB/Serial to an Arduino that runs a 512 LED array… giving me video in low-res on a panel i built. Works great until I pull the display from the Mac Mini it all runs on. When I check whats going on via screen-sharing from another machine, it appears that Syphon just is not properly working… I can fire up the Simple Server and Client, and nothing is happening. If I plug the display back to the Mac Mini, it starts to work again. Anyone done this sort of thing and gotten it to work? Any suggestions?


    So here is what I have been able to figure out. Based on this post over at Troikatronix by Mark Coniglio (developer of Isadora): http://troikatronix.com/troikatronixforum/discussion/1484/handy-adapter-allows-normal-performance-on-a-headless-mac/p1

    According to this post, the OpenGL drivers do not load on a Mac Mini if it does not detect a display attached. The link above details a hack that simply plugs a resistor into 2 holes of a mini display port to VGA adapter (not kidding), and allows them to successfully run headless at normal speeds (users were experiencing poor performance with Isadora evidently).
    I tried that and it did NOT work in my situtaion. However, what DID work, was this: I happened to have a DVI to Composite video adapter laying around, and also a Mini Display Port to DVI adapter. I plugged them in together, and hung it off the Mini, anbd voila! it all works as expected.
    This kinda does not make sense, and I was wondering if anyone can explain it. I know the jit.gl.syphon object must rely on OpenGL… so I guess it is the same deal as the Isadora issue outlined above… Open GL drivers, if not loaded, will break the Max Syphon object. Somehow the Composite adapter is fooling the Mini into thinking there is a dsiplay attached. I am attaching 2 pics of the set-up. One is the “double-dongle” and one is the LED array I am running via the Max/Processing/Serial-USB/Teensy connection.

    Headless Syphon Display Dongle

    Headless Syphon LED display


    Sorry for the delayed response – yep I’ve heard of people having to do this before, but never tried myself. Thanks for sharing the solution.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.